Apogee FX Rack Bundle

5 EQ & Compressor Plugins

Sale ends in:
  • 00

    Days

  • 00

    Hours

  • 00

    Mins

  • 00

    Secs

  • Regular price $499.00

    Cloud Icon Instant Delivery
    Digital Product - Delivered via Email.
    More Info


AAX Native - Compatible with Pro Tools 11 and above
AudioUnits Format VST2 Format
iLok account required, dongle optional
MacOS Logo

Apogee FX Rack Plugins are made with the same quest for quality and obsessive attention to detail as Apogee hardware products. Thanks to Apogee's unique DualPath DSP-Native technology, Apogee FX Rack plugins can run both on the hardware DSP in Ensemble Thunderbolt and Element Series interfaces and as native plugins on your Mac. Apogee's DualPath technology opens up a variety of popular, simplified workflows, always with the lowest latency.

Included Plugins

  • Pultec EQP-1A
  • Pultec MEQ-5
  • Opto-3A
  • ModEQ 6
  • ModComp

System Requirements

  • Mac OS X 10.12.6 or higher – 10.14 Mojave fully supported
  • 4GB minimum RAM, 8 GB or higher recommended
  • Free iLok account - iLok USK key optional

Supported DAWs

  • Logic Pro X
  • Pro Tools 12, Ultimate (ProTools 11 and lower not currently supported )
  • Ableton Live 10
  • Cubase 9.5 (VST 3 not implemented in this release )
  • Please note that any AUv2, VST 1&2, or AAX fully compliant DAW should work